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Section 2: Beam Design
In MEMS design, the beam structure has many applications, including sensors, accelerometers, and RF switches.
This section investigates two beam structures: the tethered beam, with both ends fixed, and the cantilever beam, with
one end fixed and the other end free. It also investigates several types of analyses, including
mechanical deformation and stresses



capacitance and charge



modal analysis



harmonic analysis



electrostatic spring softening



contact



pull-in



lift-off



temperature sensitivity



transient mechanical analysis

M



The table below summarizes the tutorial sections and the models used for each.
Table T2-1 Tutorial Summary
Tutorial

Description

Models needed

Page

Beam Design in
Analyzer

This basic tutorial provides a thorough explanation of how to
design a simple beam with rigid conformal supports using
Designer and Analyzer. The tutorial establishes user familiarity
with the various screens, screen fields, and settings.

tethered beam

T2-2

Modal and
Harmonic Analysis
in Analyzer

This tutorial shows how to run modal, harmonic, and
electrostatic spring softening analyses on the tethered beam

tethered beam

T2-61

Contact, Pull-in, and
Lift-off in Analyzer

This tutorial shows how to coarsen the original tethered beam
design and use it for contact, pull-in, and lift-off analyses.

tethered beam with
coarsened mesh

T2-81

Transient
Mechanical
Analysis in
Analyzer

This tutorial shows how to simulate transient mechanical
analysis using MemMech. A simple beam is fixed at one end to
simulate a cantilever beam.

cantilever beam
made of one
material

T2-105
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2.1: Beam Design in Analyzer
This tutorial provides a solution for an electrostatically actuated fixed-fixed beam with conformal supports, based on
a generalized surface-micromachining process. It gives the user basic experience with the CoventorWare simulation
environment.
Figure T2-1 shows a simple 2-D sketch of the basic model and the problems to be solved.
A parametric study using MemMech will be performed to investigate the sensitivity of the beam's mechanical
response to a fixed pressure load as a function of varying residual (internal) stress.
This tutorial introduces basic applications of the modules mentioned above in the context of a simple problem. During the tutorial, the user is encouraged to think about more complex issues that may be important for this type of
structure. For example, how important are the effects of the conformal supports? How does beam geometry (thickness, width, length, and gap) affect the behavior, and what are the sensitivities to fabrication errors in geometry? Is a
given mesh dense enough? For most design cases, asking the right questions initially is a critical step in getting an
answer that is both correct and useful.
Figure T2-1 Beam Tutorial Model
pressure load
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voltage potential

aluminum beam

oq

++++++++++++++
-----------------------ground plane

ground plane

This introductory tutorial investigates four different problems:

T2-2

"

electrostatic solution (MemElectro):
apply voltage; calculate capacitance between beam and ground

o

mechanical solution (MemMech):
apply pressure load; calculate beam displacement and stress

"

coupled solution (CoSolve):
apply voltage; calculate capacitance, beam displacement, and stress

q

parametric study:
apply pressure load; vary internal stress; calculate set of beam mechanical solutions
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Demonstrated Techniques

This tutorial covers these techniques:
entering materials into the Material Properties Database (page T2-7)



creating and editing a process flow (page T2-11)



using the 2-D layout tool (page T2-14)



building a 3-D solid model of a beam from a 2-D layout using the solid model tool (page T2-18)



creating a finite element model and mesh using the meshing tool (page T2-24)



assigning names to model components (page T2-19)



running the MemElectro module to calculate capacitance and charge (page T2-28)



running the MemMech module to calculate deformations and stresses (page T2-33)



running the CoSolveEM module to produce a coupled electromechanical solution (page T2-39)



running MemMech to perform fully coupled electrostatic analysis (page T2-45)



running a parametric study, varying model parameters (page T2-50)

2.1.2:

M



References

This beam design is a comprehensive exercise that takes you through many of the software screens. Users will likely
run this tutorial before reading much of the background and reference material found in these manuals. If you decide
to skip the reading and proceed, here are references to specific places in the manuals that may answer questions or
solve problems you may have while running the tutorials.
Using CoventorWare (page U1-1)
This introductory section briefly covers all the major design steps. It also explains CoventorWare software and
documentation conventions, directory structure, and major menu and dialog functions.
Fluidics Channel Tutorial (page M3-2)
A basic fluid channel is used to demonstrate elementary concepts to users interested in fluidics design. The tutorial, found in Microfluidics Design and Analysis Tutorials, is very similar to this Beam Design and provides additional practice on using the various software packages within CoventorWare.
DESIGNER Tutorial (page T8-1)
This tutorial covers the 2-D layout creation in detail. It shows how to create basic objects, how to correct mistakes, how to reference other cells, and how to create an array. The tutorial is found in MEMS Design and Analysis Tutorials, Vol. 2.
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Tutorial Initialization

The initialization procedure sets up the directories you will use for your files, starts the software, and creates a settings file used to store all your input and configuration parameters for the software. The first time you run the software, you will have to set a work directory, a temp directory, and a shared directory (default location). These
directories will not have to be set again.
The directory creation and file storage are automated for you. After you start the software, you need to copy the tutorial directory to your work directory. When the tutorial directory is created, all the files you need for the tutorial are
copied to the appropriate directory, and the software will default to that directory. File and directory setup has been
simplified from previous versions. All files needed for the tutorials are located in your installation directory. After
you import the tutorial directory (the BeamDesign directory), you will have a beam.cat file and a beam_init.proc file
installed in your BeamDesign\Devices directory.
This first tutorial explains procedures and file organization structure. For complete information on CoventorWare file
organization, see page U1-35 of Using CoventorWare.

Advanced User Procedure

Detailed User Procedure

1. Start CoventorWare.

a. Windows User: On your desktop, double click on the CoventorWare
shortcut icon or select Coventor > CoventorWare 2010 from the Start menu.
b. Linux User: From your Linux shell, type coventorware.

2. Set your directory and license file
preferences in the User Settings dialog.

a. If this is the first time you have run the software, the User Settings dialog
will open. See Figure T2-2.
b. Set the Work Directory: user’s root directory\Design_Files.
c. Press Enter on the keyboard and the rest of the directories will be filled in
automatically:
d. Scratch Directory: user’s root directory\Design_Files\Temp
e. Shared Directory: user’s root directory\Design_Files\Shared
 The Work directory will contain all project directories. It is also the
default location for the Shared, Temp, and Logs directories.

Â
Â

The Temp directory stores all the temporary files created by the solvers.

Â

The license fields default to the settings specified at installation.

The Shared directory contains the mpd file, which is the Material
Properties Database file that contains all the materials and their assigned
properties used in creating a MEMS design.
f. Type in the locations of your license files. You only need to set the fields for
which you have a license. For example, if you do not have an ARCHITECT/
Saber license, leave that field blank.
g. Click on OK.

Â

T2-4

The Function Manager and the Project Browser become active.
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Figure T2-2 User Settings Dialog

M

If you have an individual license, the hostname value would be the name of your machine. If you have a floating
license, your hostname value would be the name of the machine where the floating license resides. Put the name of
that machine after the @ symbol. Do not enter “hostname”.

After you set your user settings, the Function Manager, shown in Figure T2-3, and the Project Browser dialog, shown
in Figure T2-4, open. The Function Manager has tabs that access various tools needed for a MEMS design. This window is the means of navigation throughout the tutorial. When you finish one step in your design, the software returns
control to this window.
Figure T2-3 Function Manager

Before you can begin to build your design, you must create a new project directory and new project settings. Use the
Project Browser dialog to access the Tutorials projects directory, which contains the files needed to run the tutorials.
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Advanced User Procedure

Detailed User Procedure

3. Import the BeamDesign project directory
and create a settings file.

a. In the Project Browser dialog (see Figure T2-4), click on the Import
Tutorials icon.
b. In the Import Tutorials dialog that opens, select BeamDesign.
c. Click on OK.
d. Verify that the software has created a default settings file that has the
same name as the project directory name. The BeamDesign.mps settings
file should appear in the Setting file field.
e. Click on Open.

ÂWhen you select the BeamDesign directory, the software copies this
directory to your work directory. All the files needed for the tutorial
are stored in this directory, and the software will default to the
appropriate directory when looking for a file.

ÂFor more details on file organization, refer to the File Organization
section in Using CoventorWare, starting on page U1-35.

Figure T2-4

Project Browser Dialog

The Project Browser dialog has icons along the top that allow the user to import projects from previous versions of
the software, import tutorial projects, delete projects, and create new projects. The user can also delete and create new
settings files. When a project is selected or created in the Projects pane of the Project Browser dialog, a default settings file and any other settings files associated with that project are displayed in the Settings pane.
The software uses settings files to track file paths, finite-element meshes, material properties, locations of solved
model files, and other simulation parameters. Create multiple settings files when you vary designs, meshes, or boundary conditions within a single project; this will preserve each variation in an individual file for later comparison. A
default settings file based on the project directory name is automatically created for you. Use the File menu in the
Function Manager to manage projects and settings.

When naming files or directories or designating path names, do not use spaces.

T2-6
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Saving Settings
In CoventorWare, any settings established in setup dialogs are saved to local memory when Open is clicked.
However, the new or modified dialog contents are not written to the settings file. Before exiting the software, always
click on the File > Save Settings button to save the file’s contents to disk. Also, save after modifications as often as
possible to preserve data in the event of a system crash.

These steps complete the initialization procedure. Now, a project directory and settings file exist and will be modified
in the next sections of the tutorial. In this tutorial, our procedure will
check and modify the Material Properties Database



view and modify the process flow



view and modify the 2-D mask design



build a 3-D solid model



mesh the model



name faces and conductors



simulate electrostatic and mechanical stimulus

M



The order of these steps can be varied and still allow for a smooth work flow. Experienced users may wish to change
this procedure.

2.1.4:

Material Properties Database Setup

The Function Manager provides access to the Material Properties Database in the top portion of the window, above
the tabs. Material Properties Database access and setup is the first field in the Function Manager because the process
is dependent on the materials in the Material Properties Database, and in turn, the rest of the design creation is dependent on the process file. In other words, the Material Properties Database is the basic foundation of your design. This
database stores properties for materials used for MEMS design. Materials or parameters can be added or modified at
any time from this or from other dialogs in the software. The user designates the file path for the mpd file in the Users
Settings dialog the first time CoventorWare is run. This setting can be changed from the Tools > User Settings menu.
In this tutorial, the Material Properties Database is checked and validated before a process file is created because the
materials used in the process file must exist and have the correct values. The process file takes the materials and their
values from the Material Properties Database. In the next step, properties for both Silicon_100 and Aluminum Film
will be checked. These materials are used to construct the beam.
The materials and their properties provided in the default Materials Properties Database (MPD) are there to serve as
examples and to make the tutorials easier to use. CoventorWare does not supply material properties for design use.
Users should enter their own materials and properties and save them into their custom MPD file for use in their
design work.

Advanced User Procedure

Detailed User Procedure

1. Access the Material Properties Database.

a. In the Function Manager, click on the Start MPD Editor icon.

ÂThere is no need to set the Materials field for the mpd file because the
software defaults to the path set in the User Settings dialog the first
time it is run.
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Advanced User Procedure

Detailed User Procedure

2. Select ALUMINUM(FILM), which will be
the beam material, and verify its material
properties. If it is not in the MPD, add it
and use the properties shown in Table T22. Modify the Material Properties Database
if necessary.

a. In the Edit Materials dialog that opens, click on the drop-down arrow
beside the Materials field.

Â

The Material Properties Database always initially displays the material
at the beginning of the alphabet. If the default mpd file is specified,
AIR is displayed.
b. Select the material named ALUMINUM(FILM), if it appears in the dropdown menu.
c. If the material exists, check the property values against those in Table T22. Only these values must match for the tutorials. Ignore the other
settings.

Â

In this step you are verifying that ALUMINUM(FILM) exists in your
Material Properties Database and has the correct material properties.

If ALUMINUM(FILM) is not on the list:
d. Click on New Material.
e. In the dialog that opens, enter ALUMINUM(FILM).

Â

Material names can have no more than 32 characters.

f. Click on OK.

Â

You created the material, but it does not have valid properties yet.

If you just created ALUMINUM(FILM), or if its existing properties are
incorrect:
g. Set the properties for the materials shown in Table T2-2.

Â

After creating a new material, the user has to assign valid properties to
that material. These are the only properties needed for this tutorial.

3. Select SILICON_100, the substrate
material, and verify its material properties.
If it is not in the MPD, add it and use the
properties shown in Table T2-2. Modify
the Material Properties Database if
necessary.

a. Select SILICON_100 from the Materials drop-down menu.
b. If SILICON_100 is not on the list, or if the existing properties are
incorrect, repeat the parts of the procedure shown above as applicable.

4. Close the Materials Editor.

a. When finished in the Edit Materials dialog, click on Close.

Â

In this step you are verifying that SILICON_100 exists in your Material
Properties Database and that it has the correct properties assigned to it.

Â

Clicking on Close writes the changes in the new materials to the mpd
file.

Â

Control returns to the Function Manager.

The sequence on page T2-7 sets material properties for the beam design. From the MPD Editor icon, permanent
changes may be made to the database that will be valid for all future projects. The Material Properties Database
also can be accessed from within the Preprocessor. In the Preprocessor, click on the desired part in the canvas; then
select Edit > Properties. An icon in this dialog accesses the Materials Editor. Changes made from within the
Preprocessor only apply to the displayed model and are not permanently stored to the database. Refer to the
CoventorWare Designer Reference (page U2-1) for complete details.

When entering values for the Material Properties Database, do not type in any spaces between numbers or
exponents.
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Table T2-2 Material Properties for Tutorial
Data Type

Aluminum(FILM)

Silicon_100

Units

Elastic Constants

Elastic-Iso,
(Aluminum film)
Elastic-Ortho100
(Silicon_100)

E: 7.70e+04
Poisson: 3.00e-01

E1, E2, E3:
1.3018e+005
Poisson12, 13, 23:
2.78e-01
G12, G13, G23:
7.964e+04

MPa

Density

Constant-Scalar

2.30e-15

2.331e-15

kg/µm3

Stress

AnIso (Sx,Sy,Sz)

0,0,0

0,0,0

MPa

TCE

Constant-Scalar

2.31e-05

2.49e-06

1/K

Thermal Cond

Constant-Scalar

2.40e+08

1.57e+08

pW/µm · K

Specific Heat

Constant-Scalar

9.03e+14

7.03e+14

pJ/kg · K

M

Property

The final Material Properties Database setup for each material is shown in Figure T2-5 and Figure T2-6. Refer to the
CoventorWare Designer Reference (page U2-1) for more details.
Figure T2-5 Materials Properties for Aluminum(FILM)
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Figure T2-6 Materials Properties for Silicon_100

In the Edit Materials dialog, the column of buttons to the right display properties that have only a single entry. For
all other cases, the buttons retain the Edit label. For example, the single SILICON_100 Density value of 2.331e-15
is displayed on the button, while the Elastic Constants are displayed only when you click on the Edit button and
open the dialog for setting these parameters.

The value for the Dielectric Constant within the Materials Property dialog determines whether the material is
declared as a Conductor (low values) or Dielectric (high values) in the Properties dialog within the Preprocessor.
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Process Editor

The Process Editor supplies the information needed to construct the 3-D solid model of the device from the 2-D
masks viewed in the Layout Editor. Material layers are constructed in a deposit and etch sequence that emulates the
actual fabrication process. The process parameters that can be adjusted include:


material thickness (during deposition)



deposition type (stacked, conformal, or planar)



sidewall angles (profiles of the angular slope allowed during an etch operation)



a mask perimeter offset (the ability to change the mask dimensions through an undersized or oversized operation to accommodate foundry processing requirements)



mask polarity (positive or negative tone to determine whether light or dark areas of the mask are etched)

M

In photolithography, the term polarity is used to indicate whether drawn features, such as an enclosed polygon,
appear light or dark on the mask plate. In actual fabrication, the polarity of a mask determines whether a defined
shape is retained or etched away. This depends on the type of photoresist used, as well as the process by which the
material is deposited. In the Process Editor, however, positive polarity always means features are preserved, and
negative means features are etched away.

Refer to the Process Modeling section of the Using CoventorWare manual, beginning on page U3-1, for an in-depth
discussion on these topics.
Figure T2-7 is a cross-section diagram of the beam structure used in this tutorial.
Figure T2-7 Beam Cross-Section Diagram
nitride

aluminum
BPSG

ground plane

In this figure, a ground plane is overlaid with a nitride layer for isolation of the beam. A sacrifice layer of BPSG
(boron phospho-silicate glass) is deposited on the nitride layer. It is etched to define the areas where the beam will be
anchored to the nitride layer. The BPSG thickness sets the separation between the nitride layer and the thin aluminum
beam to be built on top. After the entire wafer is deposited with aluminum, a selective etch defines the actual beam
dimensions. Note that the aluminum beam conforms to the deposited BPSG, with equal thickness on the top and on
the sidewalls of the BPSG.
The BPSG is called a sacrifice layer because it is etched away when the MEMS process is complete. After the sacrifice layer is removed, the final MEMS design looks as shown in Figure T2-8.
Figure T2-8 Beam Cross-Section with Sacrifice Layer Etched

When the BPSG is removed, the fixed-fixed beam is held to the nitride by its conformal supports in the region where
the BPSG holes were created. The section of the beam in the middle is now free to deflect when an external force,
such as a pressure or electrostatic load, is applied.
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The process steps define the structure of Figure T2-7 and provide instructions for the actual fabrication of the model.
The GND layer in CoventorWare
All design structures must include a GND or base layer. This layer defines the boundaries of the model’s active area
and is not associated with an electrical ground or a deposition layer that is connected to ground.

The Process Editor is accessed from an icon in the top half of the Function Manager. The initial process flow does not
show the deposit and etch steps required to form the aluminum beam. In the steps below, the process file will be modified so an appropriate model can be built.

Advanced User Procedure

Detailed User Procedure

1. Open the beam_init.proc file in the Process
Editor.

a. In the Function Manager, click on the drop-down arrow
to the right
of the Process field.
b. Select the beam_init.proc file located in the BeamDesign\Devices
directory.
c. Click on the Process Editor icon.

ÂThe software defaults to the BeamDesign\Devices directory. The user
can browse to choose other directories and files.

ÂThe Process Editor defines a series of simple deposit and etch steps to
model the actual MEMS process.

ÂThe Process Editor displays the beam_init.proc file.
Figure T2-9

Process Editor

Process Description

Process Library

Step Parameters
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The Process Description identifies all the steps used in creating the beam design. The Process Library provides the
modeling step options. The Step Parameters pane allows the user to set parameters for a selected step in the Process
Description. The Substrate in the Process Description pane corresponds to the ground plane, the next Stack Material
corresponds to the Silicon Nitride layer, and the next Stack Material and Straight Cut steps correspond to the defined
BPSG material on which the aluminum beam is placed. Finally, the BPSG delete step is shown at the end.

Advanced User Procedure

Detailed User Procedure

2. Edit the process flow: Add a
Conformal Shell and Straight Cut
step with the attributes shown below.

a. In the Process Description pane, highlight Step 3 (Straight Cut) by clicking on
the fourth row.

Â

Selecting a row in the Process Description pane allows you to choose
whether to insert above or below the highlighted step.

M

b. On the right-hand side of the Process Editor, in the Process Library pane,
double-click on Modeling Actions to expand the folder. Right-click on
Conformal Shell and select Insert Below Current Step.
c. Right-click on Straight Cut and insert it below the current step.

Â

Clicking on the different options in the Modeling Steps folder inserts new
deposit and etch steps. The Process Library can be docked outside the
Process Editor by dragging the gray bars at the top of the Process Library
pane outside the Process Editor.

d. Highlight Step 4 (Conformal Shell) in the Process Description pane, and enter
the following attributes into the Step Parameter fields:
LayerName: enter beam (or another descriptive name)
Material: select ALUMINUM(FILM)
Thickness Nominal Value: enter 0.5
Display Color: select red

Â

The color designations for the deposits should correspond to the layer colors
that appear in the solid model.

e. Select Step 5 (Straight Cut) and enter the following attributes:
 Select Cut Last Layer Completely
 Select Front Side
 Mask: enter beam
 Photoresist: select +

Â

Step 5 creates a positive tone beam mask etch, with no oversize/undersize
or sidewall angles. All but the narrow beam will be etched away.

The beam process is now complete. The finished Process Description pane of the Process Editor should look as
shown below.
Figure T2-10 Process Editor After Edits
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Adjusting Windows for Full Field Viewing
As an alternative to using the horizontal scroll bar in the window above, the window can be stretched horizontally
to see all the fields. The column widths can also be adjusted with the mouse. Many dialogs in the software allow
horizontal and vertical adjustment, as well as resizing of individual fields or columns. The View > Columns
option can be used to select which parameters are displayed in the Process Description.

Creating a New Process Flow
The method described in Step 2 is commonly used for creating new process flows from existing file descriptions. A
new process file can be started in several ways:
 Select File > New from the Process Editor menu bar. Initially, only a base layer appears. Proceed with
developing a flow.
 Specify the create a new process option in the Process file field, and click on the Process Editor icon. When the
Process Editor opens, the base layer appears.

Advanced User Procedure

Detailed User Procedure

3. Save the file as beam.proc.

a.
b.
c.
d.

From the menu at the top of the Process Editor, select on File > Save As.
Type the new file name beam.proc in the File name field.
Click on Save.
From the File menu, select Exit.

Â
Â

2.1.6:

By default, the file is saved in the BeamDesign\Devices directory.
The file path in the Process field is updated automatically to the new
beam.proc file.

Layout Viewing and Editing

After defining material properties and the deposit and etch sequence, the next step in creating a MEMS design is creating the 2-D layout. The 2-D Layout Editor is used to create, import, view, and edit 2-D mask information. For users
with alternative software, the Layout Editor can import CIF and GDSII format files and convert them to a CoventorWare-compatible format. The Layout functions are accessed by selecting the Designer tab from the Function Manager. From this window, the user selects a cat file. The cat file is the storage location for the 2-D layout created or
edited in the Layout Editor. This cat file can include any number of individual cell layouts. The 2-D layout information can be used to create foundry masks for building the MEMS device and is used as the source for rendering a 3-D
model for meshing and solving.
In the next sequence, the 2-D mask layout will be viewed in the Layout Editor. It may appear to be a dummy step
because no changes are made to the design. Note, however, that this tutorial is a simplified example. A design may be
built or modified, or imported from another layout database. Thus, consider the next step as part of the methodology
for creating a real layout.
For practice and guidance in creating a 2-D layout, see the tutorial starting on page T8-1. For Layout Editor reference
documentation, see the CoventorWare DESIGNER Reference. You can access a PDF of this manual from the Function Manager Help > Contents option.
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Advanced User Procedure

Detailed User Procedure

1. Open the beam.cat file in the Layout
Editor.

a. From the Function Manager, click on the tab labeled Designer.

Â

The Designer tab gives the user access to the Layout Editor, the Solid
Modeler, and the Preprocessor (for viewing the 3-D model and
meshing).

b. Click on the Browse icon to the right of the Layout field.

Â

The software defaults to the BeamDesign\Devices directory.

c. Select the beam.cat file in the BeamDesign\Devices directory.
d. Click on Open.

M

e. Click on the Layout Editor icon.

Â

Figure T2-11

Coventor, Inc.

The Layout Editor main window opens, displaying the beam design.
The Terminal window can be opened by clicking on the %ca button in
the bottom of the Editor window.

2-D Layout Editor with Beam Design Displayed
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The 2-D Layout Editor will open .cat files generated in older versions of the software, but will not convert them to
the current version until the file is saved.

Advanced User Procedure

Detailed User Procedure

2. Use the Grid tool to set the Working Grid
to 5.0 and the Display Grid to 1.0.

a. From the top menu bar, select Tools > Options > Grid.
b. In the grid dialog, set the Working Grid to 5.0,5.0 so that the cursor now
snaps to the nearest 5-micron grid point.
c. In the grid dialog, set the Display Grid multiple to 1.
d. Click on Apply.
e. Click on Close.

Â

3. Use the Ruler tool to measure the beam.

The Display Grid setting displays a grid dot every 5 microns (not
every 1 micron). The multiple value is multiplied by the Working Grid
value to derive the display distance. For example, a Display Grid
multiple of 5 for the same Working Grid of 5 sets the grid dots at 25micron intervals.

a. From the top menu bar, select Tools > Ruler.
b. Click on the top and then the bottom of the red aluminum beam. The
Terminal responds with "Distance = 100.0 microns."
c. Along the top of the Layout Editor window, click on the Refresh icon
, which causes the screen to refresh and clears the ruler.

4. Access the Layer Browser.
a. Click on the Layer Browser icon.

Â
Â

The Layer Browser dialog shown below opens.
Layer information can be directly edited from within this dialog.

The Layer Browser dialog is a key element in the 2-D Layout Editor. It displays and controls various attributes,
including the following:
 Layer Name - Displays the mask layer name
 Color - Displays/controls the layer color
 Fill - Displays/controls the layer fill pattern (solid, dots, hatched, etc.)
 V - Controls the visibility of the layer
 S - Controls the selectability of the layer (for edit operations)
 Layer Polarity on Mask - Controls whether a layer is added or subtracted from the layout.
 Mask Name - Allows several layers to be assigned to the same mask
 Dark/Light Mask Field - Controls how the shape drawn by the mask appears
 SAT/IGES - Specifies the name to be used for SAT or IGES file translation
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GDS - Provides GDS layer name in Layer#Data# format.
CIF/DXF - Specifies the name to be used for CIF or DXF file translation
 Magnifier - Opens Layer dialog for editing and exporting layer properties




Note that the SAT/IGES, GDS, and CIF/DXF columns can be hidden by clicking on No IOs in the icon row.
The Layout Editor represents the BPSG as the solid yellow color and the aluminum beam in red. The next steps are a
simple exercise with the Layer Browser that changes the appearance of the layers displayed.

Detailed User Procedure

5. Use the Visibility feature to identify each
layer.

a. In the Layer Browser dialog, at the top of the Visibility column, click on
V to turn visibility off for all layers.
b. One by one, click on the boxes in the V column next to the following
layers: GND, anchor, and beam.

Â

6. Set the anchor layer fill to none.

This action toggles the visibility for each layer and allows the layers to
be identified as they appear on the screen. Clicking on V again would
also restore the original settings.

a. For the anchor layer, select the none Fill pattern.

Â

In the main window, the yellow squares of the anchor layer are now
outlines. The modified view, including grid dots, is shown below.
b. In the Layer Browser dialog, select File > Close.
7. Exit the Layout Editor

a. From the Layout Editor File menu, select Save.

Â

The file is written to the BeamDesign\Devices directory.

b. Select File > Exit.

Â

The Layout Editor section is complete. In the next tutorial sequence
you will use the 2-D layout to build your solid model.

anchor mask

beam mask

GND mask
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Building the Solid Model

Now that the process and layout files are complete, a 3-D model can be built using the thickness and etch profile
information from the process file and the 2-D layout mask information. To create the solid model, from the Designer
tab, click on the arrow beside the Model/Mesh field and select the create new model option. Then click on the Build a
New 3D Model icon. This will start the building process. When the software completes the solid model, the Preprocessor will automatically open.
The Solid Model Tool and Older Process Editor Files
If CoventorWare is used with Process Editor files created in an earlier versions, the solid model tool will not read
the older format directly. The Process Editor must be opened, the older file read in and resaved. The conversion is
automatic.

Advanced User Procedure

Detailed User Procedure

1. Build the solid model of the beam.

a. Click on the down arrow Model/Mesh field and select create a new model.
b. Click on the Build a New 3D Model icon.
c. In the Input dialog that opens, enter beam.
d. Click on OK.
e. Wait for the build to finish; the Preprocessor will automatically open.

Â

Figure T2-12

A 3-D model is built using the mask and supplied process information.
The model appears as shown in Figure T2-12. Note that the figure shows
the model with a white background and no shadow effect. These features
are controlled from the Tools > Options > View menu. See page D4-34
for more details.

Preprocessor Rendering of the Beam Model

Geometry
Browser
Canvas

T2-18

March 23, 2010

Coventor, Inc.

Section 2: Beam Design

Version 2010

The rendered 3-D beam is created from the 2-D layout drawing, with the red aluminum beam elevated and anchored
by supports to an underlying layer. The process file information allows the depth of the beam to be extruded.
Viewing control icons along the top of the window allow for rotation, zooming, and other view perspectives. These
features are detailed later in this and other tutorials.

2.1.8:

Naming Entities

The next step in the design process is to add the desired layers to the Mesh folder and assign electrical characteristics
and unique names. The entities are named before meshing because the names are actually attached to the solid model.
If you assign the names at this point, the names will perpetuate throughout all meshes created with these layers. The
names will remain even if you remesh.

Advanced User Procedure

Detailed User Procedure

1. Hide the Nitride layer.

a. In the Geometry Browser on the left side of the Preprocessor, right click
on the Nitride layer and select Hide Selection.

2. Add the Substrate and Beam layers to
Mesh folder.

Coventor, Inc.

Â

The Nitride layer will not be part of the meshed model, so hiding this
layer in the Solid Model folder makes it easier to work with the layers
that will be meshed.

Â

To view any entity that you have hidden, right click on its name in the
Geometry Browser and select Show Selection.

a. Hold down the Ctrl key and click on the Substrate layer and the Beam
layer.
b. Right click on the layers and select Add to Mesh Model.

Â

Adding the layers to the Mesh Model folder makes them available for
meshing.

Â

You are selecting only the layers of interest to be meshed. Only the
ground and beam layers are used by the solvers, so the other layers are
not added to the mesh folder.

Â

The Geometry Browser now appears as shown below.
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Naming the faces is an important step because only those faces assigned user names appear in the solver boundary
condition dialogs.
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3. Apply the Substrate properties shown
below.

a. If necessary, double click on the Substrate layer to expand the Geometry
Browser.
b. Click on Part_0(Substrate) to select.
c. Select Edit >Properties.

Â

You can also right click on the part, and select Properties.

d. In the Name field, enter ground.
e. In the Analysis options select these options:
 Conductor
 Solid
 Suppress, except for MemElectro

Â

The Suppress option removes this part from any mechanical
simulation.
f. Click on OK.

The Part Properties dialog has an icon that accesses the Materials Properties Database (MPD) Editor. The user can
make changes to material property values from this dialog, but these changes will not be written to the MPD file.
The changes will be stored in the project’s database.

Any changes entered in the Preprocessor's MPD editor are immediately saved to the currently open model/mesh
document, without waiting for the user to issue an explicit 'Save' request.
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4. Apply the Beam properties shown below.

a. If necessary, double click on the Beam layer to expand the Geometry
Browser.
b. Right click on the beam part and select Properties.
c. Verify these settings:
 Name = beam.
 Conductor
 Solid.
d. Click on OK.
The beam part has the necessary material assignments. It will remain a
movable part and therefore be a part of the mechanical simulation.

Advanced User Procedure

Detailed User Procedure

5. Set the Z scale for easier face
identification.

a. In the Preprocessor menu bar, find the Z Scale field, and select or enter a
number between 3 and 10.
b. Click on the Face Selection Mode icon.

Â

Coventor, Inc.

You are expanding the viewing height for easier face naming. The Z
Scale distorts the height of the model. Choose a number that allows
easy selection and identification of the sides and anchors of the beam.
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6. Name the top surface of the beam top. (See
Figure T2-13).

a. In the canvas area of the window, left click on the top surface of the
beam. (See Figure T2-13).

Â

Note that the Geometry Browser for beam region automatically
expands to the Part and Face level, and the corresponding Face number
for the top beam surface is highlighted.
b. Right click and select Set Name.
c. In the Set Face Name dialog that opens, enter top in the Name field.
d. Click on OK.

Â

7. Name the top surface of the substrate
ground.
8. Name the bottom of the beam bottom.

A change is made to a default face name assigned by the software. The
name top is appended to the corresponding face in the Geometry
Browser. The canvas area does not change.

a. Repeat the above procedure for the ground surface, changing the face
name to ground.
a. Click on top and then on the Hide Selection icon.

Â

This hides the top surface, revealing the beam bottom.

b. Identify the bottom of the beam and name it bottom.
9. Name the bottom anchor faces anchor1
and anchor2.

a. Hide the top face of the anchor and select the bottom anchor face (face
touching the ground surface). Name it anchor1.

Â

You need to name these faces because they will be used to fix the
anchors of the beam during the MemMech simulation. Only faces that
must be identified for solver boundary condition setup must be named
by the user. These named faces appear in the pull-down patch menus in
the boundary conditions (BC) setup dialogs.

b. Select the Rotate Model icon
anchor is accessible.

, and rotate the model so that the other

Â

When you use the rotate tool, the Face Selection Mode is no longer
active. To continue selecting faces, click on the Face Selection Mode
icon. Or to rotate a model while keeping the face selection mode
active, use the Ctrl + Right Click and drag option.
c. Reselect the Face Selection Mode icon.
d. Hide the top face of the anchor and name the bottom anchor face
anchor2.

Â

To display all the faces you have hidden without selecting them one by
one, right click on the region that contains the beam and select Show
Selection.
e. Select File > Save.
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Figure T2-13 Face Assignments
anchor2(top face hidden)

anchor1
(top face hidden)

top

ground

bottom face not
shown

M

Z scale = 5

Advanced User Procedure

Detailed User Procedure

10. Rename the conductors beam and ground.

a. In the Geometry Browser, double click on the Conductors folder to
expand the tree.
b. Right click on the Conductor entity that corresponds to the ground part
and select Set Name.
c. In the dialog that opens, enter ground.
d. Select the other Conductor.
e. Rename it beam.

Â

Coventor, Inc.

Conductor names are displayed in BC setup dialogs and in results
windows. Assigning more meaningful names makes it easier to
identify the conductors in these dialogs.
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Meshing

The next step in the design process is meshing. The model must now be meshed so the geometry of the structure can
be reduced to a group of simpler finite element bricks and presented to the solver for finite element analysis. You will
select the meshing method, and then create a mesh for the beam and the substrate. The mesh, part, and face information are stored in the project database. This database information is used in solver simulation. Figure T2-14 shows the
process flow for executing this type of sequence.The flow chart illustrates the general ways in which designs can be
built and simulated.
Figure T2-14 Meshing in CoventorWare

Material Properties Database
Process Editor

Designer tab
2-D model creation (Layout Editor)
3-D model creation

Meshing (from within the Preprocessor)
Can create different finite element
mesh for different layers
Optional: Export 3-D to external program
Optional: Import Mesh from
external program

Analyzer tab
CoventorWare Solvers
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1. Assign a Manhattan bricks mesh type to
the Substrate layer. Use the Parabolic
element type and element sizes of 2,2,and
10 in the X, Y, and Z directions
respectively.

a. From the Geometry Browser, click on the region containing the Substrate
layer.
b. Right click and select Mesher Settings.
c. Select the Manhattan bricks mesh type.

Â

The Manhattan bricks mesh option creates brick elements. This type of
meshing is used for models with orthogonal geometry, i.e all the model
faces are planar and join at 90 degree angles.

Â

Â

For more explanation of Manhattan Mesher Settings, see page R2-16.

Figure T2-15 Mesher Settings
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The Parabolic element order, the default setting, creates a hexahedron
with node solutions at 27 points (8 vertices, 12 midpoints between
vertices, 6 hexahedral face centers, and 1 center).
d. For the Element Size, enter the following:
 For X direction: 2
 For Y direction: 2
 For Z direction: 10
e. Check that the dialog parameters match those shown below.
f. Click on OK.
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2. Assign a Manhattan bricks mesh type to
the Beam layer. Use element sizes of
2,2,and 10 in the X, Y, and Z directions
respectively.

a. Click on the region containing the beam layer.
b. Apply the same mesher settings you applied to the substrate.

Â

The beam is 100 µm by 10 µm, so 250 bricks will be created for the
beam layer in the XY plane, plus another 20 bricks in the XY plane for
the anchor supports.

Â

The beam is only 0.5 microns in height, so the mesher will create a
single layer of bricks.
c. Check that the dialog parameters match those shown in Figure T2-15.
d. Click on OK.
3. Create the mesh.
a. Click on the Generate Mesh icon

Â

.

This action creates a mesh on all the regions in the Mesh Model folder.
See the resulting meshes in Figure T2-16.

Figure T2-16 Meshed Beam and Substrate

Z Scale = 1

Choosing an Adequate Mesh
In this tutorial, the mesh settings for the model are provided, but when meshing your own design, it is important to
conduct a mesh study to verify that you have used a sufficiently refined mesh to accurately model your device. Computer resources required to run your simulation increase as the mesh is refined; therefore, it is important to optimize
your mesh so that you can obtain acceptable results in an acceptable amount of time. The numerical solution provided
by your model will tend toward a unique value as you increase the mesh density. The mesh is said to be converged
when further mesh refinement produces a negligible change in the solution.You can be confident that your model is
producing a mathematically accurate solution if the two meshes give essentially the same result.
To conduct a mesh convergence study, create multiple models that have different element sizes. You may want to vary
the mesh in only one direction of interest. For example, if your device will experience a lot of stress in the Z direction,
you may want to vary the mesh only in that direction.We chose to vary the beam mesh in each direction as follows:
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first model with element size = x



second model with element size = x/2



third model with element size = x/4
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Run the same analysis on each mesh and compare results. For this particular device, models with mesh densities of x/
2 and x/4, yielded results that were less than one percent in variation from the tutorial mesh, but took a significantly
larger amount of simulation time. The mechanical results from each mesh are listed below:
Table T2-3 Mechanical Results of Mesh Convergence Study
Mesh Size in X, Y, Z
direction

Max. Node
Displacement

% Difference

Tutorial mesh

2.0, 2.0, 10

1.510403E-01

NA

Tutorial mesh/2

1.0, 1.0. 5.0

1.516704E-01

0.42%

Tutorial mesh/4

0.5, 0.5, 2.5

1.519611E-01

0.61%

M

Mesh model

Refining the mesh any further than what is specified in the tutorial leads to negligible differences in results, but
increases simulation time.
Note that for this example, the point of interest was the mechanical displacement. You could also run the same example with MemElectro to check for convergence of the electrostatic results. Convergence in one type of simulation
does not imply convergence in all types of simulations. When conducting a mesh study, consider which type of physical phenomenon you would like to investigate, then choose your module accordingly.
For more information on mesh convergence studies, see page R3-5 and page R4-14.
To see a Quality Query, right-click on a region and select Quality Query. Figure T2-17 shows the results of a Quality
Query performed on the substrate region of the beam model.
Figure T2-17 Quality Query on Substrate Region

The meshing step is complete, except for saving the file.
Save the File
After renaming entities in the Preprocessor, it is critical to save the changes using the File > Save option. After
performing the naming sequence a few times, it can be very easy to forget this step.

Coventor, Inc.
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4. Save the model and close the Preprocessor.

a. Click on File > Save.
b. Click on File > Exit.

Â

The necessary model preparation steps have been completed. You will
now begin running simulations.

2.1.10: MemElectro
The MemElectro solver produces an electrostatic solution by solving for the charge and capacitance interaction
between the beam and ground components of the created model. MemElectro uses the Boundary Element Method
(BEM). During the calculation, MemElectro computes the charge on each surface panel and presents a final solution
with charge distribution calculated for all the panels in the model.
This process is started from the Analyzer tab, used for accessing the core solvers used in this tutorial. The MemElectro, MemMech, and CoSolveEM modules are all used for this tutorial.
Advanced User Procedure

Detailed User Procedure

1. Set up the Analyzer tab to point to the
MemElectro solver for the beam model.

a. From the Function Manager, click on the Analyzer tab.
b. Click on the arrow to the right of the Solver field, and from the dropdown menu, select MemElectro.
c. Click on the arrow beside the Model/Mesh field. Select the beam model.

Â

The Model/Mesh field defaults to the model created in previous steps.
Use Browse icon to the right of this field to select other models.
d. In the Analysis field, make sure create a new analysis is displayed.

Â

You do not have to specify an analysis results directory in the Analyzer
tab. You will specify a directory before the simulation begins.
e. Click on the Solver Setup icon.

Â

Clicking on Solver Setup opens the MemElectro Settings dialog, which
configures the solver for the type of problem presented to it.

Solver Setup icon
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The number of solver categories and solver types that a user can access is dependent on the specific licensed
configuration of CoventorWare.

The Solver Setup icon also has two other options: Load Setup from Previous Analysis and View Results. Both
options become active when an analysis results directory from a previous run is selected in the Analysis field. The
Load Setup from Previous Analysis option loads the boundary conditions used in the selected analysis. The View
Results option opens the Analysis Results window, which allows the user to view the table and graphical results of
a previously run solution without running through the complete solver setup and execution sequence. For
consistency, the name Solver Setup will be used for this icon, even when a different option is selected.

M

Advanced User Procedure

Detailed User Procedure

2. Verify the default MemElectro settings.

a. In the MemElectro Settings dialog, verify the default settings shown in
the screen shots below.

Â

The Settings dialogs allow parameters to be specified to run the
electrostatic solver. The default settings are correct for this tutorial.
The Settings dialogs only need to change from their default settings for
very complex models requiring changes to achieve convergence or
optimize speed.
b. Click on Next.

Â

Coventor, Inc.

Clicking on Next opens the solver BCs dialog, where simulation
conditions are set.
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3. In the ConductorBCs dialog, apply a
voltage of 0 to the ground and a voltage of
1 to the beam.

a. In the MemElectro BCs dialog, click on ConductorBCs.
b. Modify the dialog so the conductor ground has a 0.0 volt stimulus
applied and the conductor beam has a 1.0 volt stimulus applied.
c. Click on OK.

Â

A voltage difference is required between the beam and the ground to
compute a charge for the structure.

Advanced User Procedure

Detailed User Procedure

4. Start the simulation.

a. In the MemElectro BCs dialog, click on Run to start the simulation.
b. In the Run Analysis dialog that opens, enter electro_run1, and click on
OK.

Â

The Run Analysis dialog allows the user to name or select a result
analysis, which will be written to the project database. If an analysis is
selected from the Analyzer tab, that analysis is displayed, but the user
can opt to select another analysis.

Â

The user also has the option to run the analysis at a later time using the
Add to Job Queue and hold or Save for Batch Run options. See page
U1-28 of Using CoventorWare for more information.
c. In the Confirm dialog click on Yes.

Â

When the simulation starts, the Job Queue dialog opens. It can be used
to monitor simulation progress and to access simulation results.

During the solver setup, if existing analysis results will be overwritten, a warning message appears:
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This dialog appears for all of the solvers when an overwrite is about to occur. Confirm by clicking on OK.
Activity during the computation appears in the normally minimized log window on the screen.

Advanced User Procedure

Detailed User Procedure

5. When the simulation is finished, open the
Analysis results for the electro_run1
simulation.

a. When the Job Queue dialog indicates that the simulation is finished
(green check mark appears by the electro_run1 job), click on the View
Results icon.

Â

The Analysis Results window opens with access through a drop-down
menu for capacitance, voltage, and charge results. This window also
has access to 3-D visualization results and Query analysis.

M

Select numerical results
View numerical results
Start a query

View results in 3-D

Advanced User Procedure

Detailed User Procedure

6. View the electrostatic results.

a. Click on the arrow beside the Tables field and select Capacitance Matrix
(pF) from the drop down menu.
b. Click on the View Table icon.
c. Verify the results shown below, then click on OK.

Â

The Capacitance Matrix dialog shows the capacitance values for the
beam problem.
d. Select Voltage and Charge on Conductors from the Tables drop-down
menu and click on the View Table icon.
e. Verify the results shown below, then click on OK.

Â

Coventor, Inc.

The Voltage and Charge on Conductors dialog shows the
corresponding charge for the voltages applied, using the capacitance
solution in the Q=CV calculation.
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The Capacitance Matrix dialog shows several values of capacitance, with all units in picofarads. Values where the
names match (i.e. beam-to-beam capacitance) represent the self-capacitance due to stored charge on the device. Note
that the rows and columns of this matrix add up to zero. By CoventorWare’s convention, self-capacitance terms
(located on the diagonal of the capacitive matrix) should be positive. Mutual-capacitance terms (off-diagonal elements) should be negative. A Capacitance Matrix dialog that deviates from this rule is an indication that the mesh
needs to be refined.
Refer to the CoventorWare ANALYZER Reference (page R3-7) for an explanation of the derivation of this capacitance
matrix.

Advanced User Procedure

Detailed User Procedure

7. Use the Visualizer to view the 3-D charge
results.

a. Click on the View 3D Results icon.

Â

Note that with this MemElectro simulation, the Charge Density values
are already loaded and displayed in the Visualizer.
b. Select Coventor > Geometry Scaling.
c. In the Scaling panel that opens, change the Z Scale field to 5. Click on
Apply, then on Close.

Â
Â
8. Close the Visualizer, and the MemElectro
results dialog.

Changing the Z Scale field distorts the view for an enhanced view.
The image appears as in Figure T2-18.

a. From the Visualizer menu bar, select File > Exit.
b. From the Analysis Results dialog, click on Close.
c. In the Job Queue dialog, click on Hide.

Â
Â

This completes the MemElectro step.
Control returns to the Function Manager Analyzer tab.

Figure T2-18 Modified Surface Charge View
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2.1.11: MemMech
MemMech computes the mechanical solution for the beam problem. The solver uses the finite element method to
solve for mechanical stress and displacement at each node on each brick created for the model. For the simple tutorial
problem, the calculation is fast.

Advanced User Procedure

Detailed User Procedure

1. Set up Analyzer tab to point to the
MemMech solver for the beam model.

a. Click on the arrow to the right of the Solver (effects) field, and from the
drop-down menu, select MemMech.
b. Select the beam model.
c. Click on the Solver Setup icon.

2. Verify the default settings in the
MemMech Settings dialog.

Coventor, Inc.

M

Â

MemMech uses the model file information stored in the project
database to compute a mechanical solution.

a. Check that the defaults settings are as shown below.

Â

This Settings dialog displays the current settings for the mechanical
solver. Other settings allow for modal and harmonic analysis and are
covered in later tutorials and in the CoventorWare ANALYZER
Reference.
b. If you are using external ABAQUS, click on the Advanced button and
select Yes for Use external Abaqus? (ABAQUS users, see page R4-75 of
the Analyzer Reference).
c. In the MemMech Settings dialog, click on Next.
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MemMech BCs Window
The hierarchical MemMech BCs window provides access to dialogs that set the boundary conditions for the MemMech solver. Usually, only one or two dialogs need to be set for any given problem.
In the next step, boundary conditions will be assigned for the model through the MemMech SurfaceBCs dialog, illustrated in Figure T2-19. The left section of the SurfaceBCs boundary conditions dialog allows specification of which
surfaces of the beam model receive a mechanical stimulus. Surfaces are specified by using the face names created in
the Preprocessor (only user-named faces appear in the pull-down menus). These faces correspond to patch names in
the boundary condition dialogs and can be controlled in a variety of ways, including applying loads or specifying that
patches remain stationary in the X, Y, or Z axes. Boolean capability allows a selection of the union or intersection of
patches when applying forces.
With the LoadPatch type already selected, the right section of the SurfaceBCs dialog allows the user to apply a pressure load to the patch surface in a variety of ways, including a scalar load in a direction normal to the patch or a vector
load in any direction. Value dialogs are used to enter these values.
Before executing the next sequence of steps, note that the Surface BCs dialog specifies AND and OR functions; these
apply to unions and intersections correspondingly akin to similar logical values. The distinction is further defined
within the Step table.
Figure T2-19 MemMech SurfaceBCs Setup
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3. In the SurfaceBCs dialog, fix the anchor
faces.

a. Click on SurfaceBCs from the MemMech BCs window.
b. Modify Set 1 as described below:
 For FixType, select fixAll.
 For Patch1, select anchor1.
 For and1, select or.
 For Patch2, select anchor2.
 The rest of the Set 1 line does not change.
A Set describes a particular set of conditions. It associates patches with
a specified action.

Â

During the model calculations, the patches assigned are assumed to be
stationary in the X,Y, and Z directions.The patches named anchor1 and
anchor 2 are designated as fixed, so they do not move during the
calculations.

Â

In this context, or is used as an additive quantity (the union of two
entities). It says that in addition to anchor1, the entire next patch
specified also has the same Fix Type applied. Do not use and here; the
anchor1/anchor2 surfaces have no common intersection.

a. Modify Set 2 as described below:
 For FixType, select LoadPatch.
 For Patch1, select top.
 Do not change any of the Boolean settings.
 For LoadValue type, select Scalar.
 For LoadValue, enter 0.001.

Â
Â

The load is applied to the entire top surface, and only the top surface.
The load is applied in the -Z direction, with a magnitude of 0.001
MegaPascals.

Â

None of Sets 3-8 are used. The none setting (set by default) tells the
software to ignore the entire line. Note that if the first column of a row
is set to none then the entire line is ignored.
b. The Surface BCs dialog should now be set as shown in Figure T2-19.
Click on OK.

The remaining sections of the boundary conditions setup are inactive. Quickly review the screens to become familiar
with them and to verify that no conditions are set. For further information on the functionality of the other boundary
conditions in MemMech, refer to the CoventorWare ANALYZER Reference.

Advanced User Procedure

Detailed User Procedure

5. Start the MemMech simulation.

a. In the MemMech BCs window, click on Run.
b. Save the analysis results as mech_run1.
c. Click on Yes to save project settings.

Coventor, Inc.

Â

When you save the settings at this point, all the file pointers and BC
dialogs that you have set are preserved.

Â

The mechanical solver starts. Simulation time varies according to the
user’s computer configuration.
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4. Apply a 0.001 MPa load to the top patch.

Â
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6. Verify the mechDomain results.

a. When the simulation is finished, click on the View Results icon in the Job
Queue dialog.
b. Select mechDomain from the Tables drop-down menu.
c. Click on the View Table icon to review the mechanical results.

Â

The mechDomain dialog shows the maximum and minimum of both
the magnitude of the displacement vector over the entire solution
domain, as well as the maximum and minimum of each of the
components.
d. Click on OK.

Advanced User Procedure

Detailed User Procedure

7. Verify the rxnForces results.

a. Select rxnForces from the Tables drop-down menu, then click on the
View Table icon.

Â

The rxnForces dialog shows the reaction forces that develop at the
fixed ends when a pressure load is exerted downward.
b. Click on OK.
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8. View the 3-D mechanical results.

a. Click on the View 3D Results icon.

Â

Â

Deform Using Displacements and Exaggeration settings display beam
deflection.

Â

Note that the Deform Using Displacements setting shows the physical
deformed shape, deformed with the displacement vector. It does not
depend on the selected contour.

Â

The display shows a color map of surface stress along the beam
surface, illustrated in Figure T2-20.

Â

Maximum deflection is at the beam center, but maximum surface stress
is at the fixed anchors.
i. Select View > Fit Everything.
j. Adjust Rotation and Scale for best viewing.
9. Exit the Visualizer, and close the Analysis
Results window.

Figure T2-20
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a. From the Visualizer menu bar, select File > Exit.
b. Click on Close to close the Analysis Results window.
c. In the Job Queue dialog, click on Hide.

Beam Surface Stress View in Visualizer
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b.
c.
d.
e.
f.
g.
h.

For mechanical simulations, the default view does not show parts that
were designated Suppress, except for MemElectro in the Preprocessor.
To show the substrate, select Coventor > Parts Visibility, and move
ground from the Hidden list to the Visible list with the Show button.
From the Visualizer menu bar, select Plot > Contour/Multi-coloring.
In the dialog that opens, select Mises Stress from the drop-down menu.
Click on Close.
Select Coventor > Geometry Scaling.
In the dialog that opens, set Scale Z to 5.
Select Deform Using Displacements, and set the Exaggeration to 15.
Click on Apply; click on Close.
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The illustration in Figure T2-20 shows colors of the frame background, color map legend, and 3-D axis symbol
reversed from the default display. To change the background to white and the legend and 3D axis symbol to black,
run the White Background macro, accessed from Tools > Quick Macro Panel.

The Visualizer has many different functions for analysis and display. The on-line help, accessed from the Help
menu, covers all of these modes in detail. Visualizer functionality that is specific to CoventorWare is detailed in the
CoventorWare ANALYZER Reference (starting on page R10-1).

To see the relative effects of the applied pressure, perform the following exercise:

Advanced User Procedure
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10. Rerun the MemMech simulation with a
surface load of 0.005.

a. From the Analyzer tab, click on the drop-down arrow beside the Solver
Setup icon, and select Solver Setup.
b. Click on Next in the Settings dialog.
c. Click on SurfaceBCs, and change the Scalar force to 0.005.
d. Rerun the simulation and save the new analysis to mech_run2.

Â
11. Observe and compare the new results with
the results from mech_run1.

This setting allows you to observe the relative displacement effect with
an increased pressure.

a. When the simulation is finished, make sure that mech_run2 is selected in
the Job Queue window, and click on the View Results icon.
b. In the Analysis Results window, select mechDomain.
c. Compare the results shown below with those from the original exercise.

Â

The increased scalar force increases deflection, but the relationship is
not linear.
d. Close the Analysis Results window and the Job Queue dialog.
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2.1.12: CoSolveEM
The CoSolveEM tool couples the electrostatic and mechanical solvers. In an iterative process, the electrostatic results
are input to the mechanical solver, and the results are fed back and forth between the solvers until convergence is
reached.

MemMech Setup for CoSolveEM
Before beginning with the CoSolve setup, go to the MemMech setup and change the surface boundary conditions. In
the last MemMech simulation, a 0.005 MegaPascal pressure load was applied when the boundary conditions were set.
For the CoSolve run, remove the pressure and observe the mechanical deflection that takes place due solely to the
electrostatic charge attracting the beam. The following steps are similar to the MemMech portion of this tutorial.

M
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1. Set the MemMech SurfaceBCs LoadValue
to 0.

a. Verify that the MemMech solver is still selected.
b. Click on the drop-down arrow beside the Solver Setup icon and select
Solver Setup.
c. Click on Next.
d. In the dialog that opens, click on SurfaceBCs.
e. Change the Set2 LoadValue to 0.0. The dialog appears as shown below.

Â

External pressure loads must be removed for this problem.

f. Click on OK in the SurfaceBCs dialog.
g. Click on Close in the MemMech BCs window.

Â

Coventor, Inc.

Clicking on Close will not initiate the solver. MemMech is accessed to
set relevant boundary conditions.
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2. Set up the Analyzer tab to point to the
CoSolve solver for the beam model.

a. From the Analyzer tab, set the Solver field to CoSolveEM.
b. From the Model/Mesh drop-down menu, select the beam model.
c. Click on Solver Setup.

Â
Â

3. Configure the CoSolve solver to run with
Single Step and the Relaxation settings.

The setup is nearly the same as for MemElectro and MemMech.
CoSolve sets parameters, changes settings for electrical and
mechanical stimuli, and performs a coupled solution using electrostatic
and mechanical solvers.

a. In the CoSolveEM Settings dialog, set the Independent Variable to
Voltage.

Â

The Settings dialog controls convergence settings, CoSolve tool
parameters, and the type of iterative analysis performed.
b. Set the Analysis Options field to Single Step.
c. Set the Iteration Method to Relaxation.

Â

The Iteration Method allows the solver to iterate until the solutions
converge (using relaxation or Newton techniques) or perform a single
combined electrostatic and mechanical solution step. Other
convergence parameters can be set from the Advanced Settings dialog.
For more details on these settings, see page R5-6.
d. Click on Next.
e. Click on OK in the warning dialog.
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4. Apply a voltage of 20 volts to the beam.

a. In the CoSolveEM BCs window click on ConductorBCs.
b. Change the voltage for the beam to 20 volts.
c. Click on OK.

Â

The voltage is increased to increase the electrostatic charge that
develops. Without an applied pressure load, the beam deflection will
come solely from this charge.

a. In the CoSolve BCs window, click on Run.
b. Save the analysis as cs_run1.
c. In the Save Settings dialog click on Yes.
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6. View the numerical displacement results.

a. When the simulation is finished, in the Job Queue dialog click on the
View Results icon.
b. Select Displacement from the Tables drop-down menu, and click on the
View Table icon.
c. Click on OK.

Â

M

5. Start the CoSolve simulation.

This action displays the computed mechanical displacement of the
beam.

The window shows the beam displacement in the X,Y, and Z directions after iterating until convergence is reached. In
3-D space, there may be a range of nodal displacements. The Max and Min columns show the limit values for this set.

Coventor, Inc.
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7. View the Capacitance results.

a. Select Capacitance to view the electrostatic portion of the results.

Â

This window summarizes the capacitance matrix electrostatic results.

b. Click on OK.
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8. View the Voltage results on Conductors.

a. Select Voltage to view the voltage for the conductors.

Â

This window summarizes beam and ground voltage results.

b. Click on OK.

Advanced User Procedure

Detailed User Procedure

9. View the Charge results on Conductors.

a. Select Charge to view the charge for the conductors.

Â

This window summarizes beam and ground charge results.

b. Click on OK.

Advanced User Procedure
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10. View the Reaction Force results.

a. Select Reaction Force to view the reaction forces portion of the solution.

Â

This window lists the forces at the fixed anchors.

b. Click on OK.

T2-42

March 23, 2010

Coventor, Inc.

Section 2: Beam Design

Version 2010

Advanced User Procedure

Detailed User Procedure

11. View the 3-D charge results.

a. Start the Visualizer by clicking on the View 3D Results icon.
b. In the MemElectro Results frame, select Coventor > Geometry Scaling,
and set the Z Scale to 5.
CoSolve produces both electrostatic and mechanical solutions,
showing both charge and deflection in the same run.When CoSolve
results are loaded into the Visualizer, the MemElectro and MemMech
results are displayed in separate frames.
c. Select Plot > Contour/Multi-coloring, and display the Charge Density
results.
d. Select View > Fit Everything. The results are shown in Figure T2-21.

Â

Observe that the charge value is about the same as when MemElectro
was run.

Figure T2-21 CoSolve Surface Visualization of Results
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12. View the 3-D mechanical results.

a. Select Frame > Push Active Frame.

Â

The MemMech results are displayed in a separate frame, this action
brings the frame forward and makes it active.

Â

For mechanical simulations, the default view does not show parts that
were designated Suppress, except for MemElectro in the preprocessor.
To show the substrate, select Coventor > Parts Visibility and move
ground from the Hidden list to the Visible list with the Show button.
b. Select Plot > Contour/Multi-coloring, then select Mises Stress.
c. Set the Geometry Scaling dialog as follows:
 Scale Z = 5
 Select Deform Using Displacements
 Exaggeration = 50.
d. Select View > Fit Everything.

Â
Â

The results are shown in Figure T2-22.

The mechanical deflection is much less because the beam bends from
the electrostatic charge only without any external pressure applied.
e. Close the Visualizer and the Analysis Results window.

Figure T2-22 CoSolve Mechanical Results
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2.1.13: MemMech Coupled Electrostatic Analysis
MemMech provides a capability for performing fully coupled electrostatic analysis. This capability will be demonstrated here, and the results are compared with those obtained from the CoSolveEM simulation in the previous section.
Because the substrate is much thicker than the beam, the deformation of the substrate will be small compared to that
of the beam. For this reason, the substrate will be meshed with just a single element.

For more information on coupled mechanical-electrostatic analysis, see page R4-62 of the Analyzer Reference.

M
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1. Remesh the beam’s substrate region using
mapped bricks, linear element order, and
an element size of 130. Unsuppress the
substrate.

a. From the Function Manager/Analyzer tab, click on the Start
Preprocessor icon beside the Model/Mesh field to open the beam model.
b. In the Geometry Browser, right click on Region 1 (the substrate layer)
and select Mesher Settings.
c. Change the Mesh Type to Mapped bricks, the Element Order to Linear,
and the Element Size to 130.0. Click on OK.
d. Right click on Region 1 and select Properties. In the dialog that opens,
un-check the Suppress, except for MemElectro option.

Â

You cannot apply electrostatic boundary conditions to parts that are
suppressed. For this simulation, you will set an electrostatic boundary
condition between the bottom of the beam and the top of the ground.
e. From the Preprocessor icon menu, click on Generate Mesh. The model
should appear as shown below.
f. Select File > Save As and save the model as beam_coupled.
g. Select File > Exit to close the Preprocessor.

Figure T2-23 Region 1 Mesher Settings and Resulting Mesh
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2. Configure the MemMech solver to use the
beam_coupled model and use its default
solver settings.

a. From the Analyzer tab, select MemMech from the Solver drop-down
menu and make sure the beam_coupled model is selected in the Model/
Mesh field.
b. From the Analysis field drop-down menu, select create a new analysis,
and then click on the Solver Setup icon.
c. In the MemMech Settings dialog, make sure these options are set:
 Physics: Mechanical
 Linear or Nonlinear?: Nonlinear
 Time Dependence: SteadyState
 Additional Analysis: None
d. Click on Next.

3. In the SurfaceBCs dialog, fix the anchor1,
anchor2, and ground patches. Apply a 20
volt potential between the ground and
bottom patches.

a.
b.
c.
d.
e.
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4. Designate the bottom and ground as the
electrostatic surfaces.

a. Click on ElectroStaticBCs.
b. For Set1, set Surface_1 to bottom and Surface_2 to ground.

Click on SurfaceBCs.
Apply a fixAll FixType to anchor1 or anchor2 or ground (see below).
Apply a Potential FixType to ground with a LoadValue of 0.0.
Apply a Potential FixType to bottom with a LoadValue of 20.0.
Click on OK.

Â

MemMech creates a set of finite elements between the surfaces to
model the electrostatic forces. Surface_1 controls the definition of the
mesh. For each solid element face on Surface_1, an electrostatic
element is created that spans the space between Surface_1 and
Surface_2.
c. Click on OK.

T2-46

March 23, 2010

Coventor, Inc.

Section 2: Beam Design

Version 2010

Advanced User Procedure

Detailed User Procedure

5. Run the analysis and view the results.

a.
b.
c.
d.

In the MemMech BCs window, click on Run.
Save the analysis as electrostatic_mech.
In the Save Settings dialog click on Yes.
When the simulation is finished, click on the View Results icon in the Job
Queue dialog.
e. Select mechDomain from the Tables drop-down menu and click on the
View Table icon.

M

This window shows the maximum (or minimum) beam displacements in the X, Y, and Z directions for the converged
solution. Note that the Minimum value of Node Z Displacement of -0.055 microns compares closely with the value
obtained from CoSolveEM for the same model (-0.059; see page T2-41).
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6. View the 3-D mechanical results.

a. Start the Visualizer by clicking on the View 3D Results icon.
b. Select Coventor > Parts Visibility, and hide the ground part.

Â

Hiding the substrate makes it easier to view the beam results.

c. Select Plot > Contour/Multi-coloring, then select Mises Stress.
d. Select Coventor > Geometry Scaling and set the following parameters:
 Scale Z = 5.0
 Select Deform Using Displacements.
 Exaggeration = 50.
e. Select View > Fit Everything.

Â
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The results are shown in Figure T2-24. As expected, this result is very
similar to the CoSolveEM results shown in Figure T2-22 on page T244.

March 23, 2010

T2-47

Section 2: Beam Design

Version 2010

Figure T2-24 MemMech Coupled Electrostatic-Elastic Results

For some MEMS devices such as switches, it is important to know the time required to move parts of the device from
one position to another. This information can be obtained by performing a transient analysis in MemMech. To demonstrate this capability, we will calculate the transient response of the beam to the same electrical potential loading
considered above.
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7. Configure the MemMech solver to use the
beam_coupled model and transient solver
settings.

a. From the Analyzer tab, select MemMech from the Solver drop-down
menu and make sure the beam_coupled model is selected in the Model/
Mesh field.
b. From the Analysis field drop-down menu, select create a new analysis,
and then click on the Solver Setup icon.
c. Set the MemMech Settings dialog as shown below.
d. Click on Next.
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8. Verify the SurfaceBCs and
ElectroStaticBCs dialogs.

a. In the SurfaceBCs dialog, verify that the entries in the table are
unchanged from the previous analysis.
b. Verify that the ElectroStaticBCs dialog is unchanged from the previous
analysis.

9. Run the analysis and view the results.

a.
b.
c.
d.

Â

This analysis may take as long as 1/2 an hour to complete.

e. Select dyna from the Graphs drop-down menu and click on the View
Graph icon.
f. Click on Mapping Style.
g. In the dialog that opens, click on the Max Disp Mag Map Name to select
it.
h. Click on and hold Map Show to select Show Selected Only, then close the
Mapping Style dialog.

Â

Note that the maximum absolute displacement at approximately 1.5 µs
is 0.096 µm. This is nearly twice the value of 0.055 µm obtained in the
static analysis.

ÂThe published graph format was created using a Visualizer macro. See
the Visualizer section in the CoventorWare ANALYZER Reference,
page R10-35, for details.

Figure T2-25 Transient Results of Beam Loaded with Electrical Potential
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In the MemMech BCs window, click on Run.
Save the analysis as electrostatic_trans_mech.
In the Save Settings dialog click on Yes.
When the simulation is finished, in the Job Queue dialog, click on the
View Results icon.

